Skip to main content

Two zero-day vulnerabilities have been discovered in Apple Products and they have pushed out an emergency update. Cyber74 is urging you to update your Apple devices to the latest version as soon as possible.

Devices Affected:

  • Macs running macOS Monterey running versions prior to 12.5.1
  • iPhone 6s and later running iOS versions prior to 15.6.1
  • iPad Pro (all models), iPad Air 2 and later, iPad 5th generation and later, iPad mini 4 and later, and iPod touch (7th generation) running iOS versions prior to 15.6.1

What This Means to You

These vulnerabilities could allow a cybercriminal to plant malware on your device when viewing a seemingly innocuous webpage or to gain administrative level privileges on your device which would allow them access to the entire device.

You can learn more about these vulnerabilities here:

 

Cyber74 Offers Expertise in Cybersecurity Solutions

At Cyber74, we offer complete cybersecurity solutions for small and medium-sized businesses, government entities, and healthcare institutions. We can assess the security needs of your business and help ensure that your business remains protected so you can continue focusing on your business objectives. Contact us here if you have any questions or want to learn more about how Cyber74 can help your organization.